Back to overview
Degraded

Delays in transaction processing

Jul 27, 2026 at 3:18pm UTC
Affected services
MLOps

Updated
Jul 27, 2026 at 5:27pm UTC

We are seeing recovery across the transaction processing pipeline, and pending transactions are completing normally. We are monitoring to confirm full stability before resolving this incident. No customer action is required, and no duplicate or incorrect charges have occurred.

Updated
Jul 27, 2026 at 5:07pm UTC

A fix has been deployed to production to address the delays in the transaction processing pipeline. Transactions are beginning to recover and the queue of pending transactions is clearing.

Updated
Jul 27, 2026 at 3:25pm UTC

We have identified an issue in our transaction processing pipeline that slowed the completion of a subset of transactions.

Created
Jul 27, 2026 at 3:18pm UTC

We are investigating delays affecting transaction processing. Some purchases may remain in a processing state longer than usual and may not complete immediately. Devices remain online and purchases can still be made. No incorrect charges have been applied.